Apache 2.2.14 — require directives present and no Authoritative handler

Раздел: FreeBSD, Советы
Написано: 25.04.2010
Автор: Antonio
Просмотров темы: 4 551 раз

Поставил как-то на новый сервер новый Apache 2.2.14, обычно использовал ветку 1.3, но решил попробовать новую 2.2.х.

logo apache

И вот заметил, что не работает авторизация стандартным методом с использованием .htaccess в логах ругается так «require directives present and no Authoritative handler».

Начал изучать эту тему, все как положено прописано в .htaccess, файлы с закриптоваными паролями лежат где нужно, но в каталог после ввода пароля не пускает!

Решение: апач необходимо устанавливать с модулем mod_authz_user.so!
Опция при сборке из портов: [X] AUTHZ_USER Enable mod_authz_user


1 звезда2 звезды3 звезды4 звезды5 звезд (1 оценок, в среднем: 5,00 из 5)

Поделиться с друзьями:

Ещё похожие заметки:



Написать


Копирование информации с сайта возможно только с указанием прямой ссылки - https://nemcd.com