phpMyAdmin и MYSQLI (Improved MySQL support)

Раздел: FreeBSD
Написано: 16.06.2008
Автор: Antonio
Просмотров темы: 3 753 раз

Устанавливал phpMyAdmin 2.11.6 на новый сервер и обратил внимание на опцию «[ ] MYSQLI    Improved MySQL support«, решил найти что это такое и нужно ли оно мне (phpMyAdmin’ом особо не пользуюсь, но имею его под рукой)

Из мануала
phpMyAdmin может соединяться с вашим MySQL сервером, используя классические php-расширения: MySQL и его усовершенствованный вариант MySQLi, который доступен в php 5.0. И в том и другом случае, разработчики обоих расширений рекомендуют использовать классическое расширение для MySQL 4.0 и ниже и MySQLi для MySQL 4.1 и новее.

При компилировании php, настоятельно рекомендуется, вручную связать выбранное Вами MySQL расширение с клиентской библиотекой MySQL по крайней мере с упрощенными версиями, которые присутствуют в дистрибутивах php. Чаще всего библиотеки, входящие в дистрибутив php — старые, их использование может вызывать проблемы. Если Ваш веб-сервер запущен под Windows вы можете попробовать MySQL Connector/PHP вместо MySQL / MySQLi расширений, который входит в состав сборки php под Win32.
MySQL 5.1 еще не поддерживается.

Ну раз разработчики рекомендуют, то отчего бы и не поставить?
Тем более что mysql-server-5.0.x.


1 звезда2 звезды3 звезды4 звезды5 звезд (Пока оценок нет)

Поделиться с друзьями:

Ещё похожие заметки:



Написать


Копирование информации с сайта возможно только с указанием прямой ссылки - https://nemcd.com