pkg(8) must be version 1.3.8 or greater, but you have

Раздел: FreeBSD
Написано: 11.10.2014
Автор: Antonio
Просмотров темы: 2 050 раз

При установке пакета на FreeBSD 10 вылазит такое..

pkg(8) must be version 1.3.8 or greater, but you have 1.2.7_3.

Похоже пора обновлять pkg

FreeBSD 10 daemon


Встречал совет использовать portupgrade для обновления pkg, но бывает такое что portupgrade не установлен и обновить им не получится.

Еще такая конструкция, я ее не проверял.

cd /usr/ports/ports-mgmt/pkg && make deinstall reinstall

Вот что помогло — выполняем и подтверждаем действие

pkg upgrade

pkg upgrade freebsd 10

Пакет pkg успешно обновлен.

Фразы: как обновить pkg freebsd, ошибка при установке порта 1.3.8 or greater


1 звезда2 звезды3 звезды4 звезды5 звезд (1 оценок, в среднем: 5,00 из 5)

Расскажи всему миру

Ещё похожие заметки:


2 комментария

kaurych
Окт 2, 2015 at 9:35

Это из за зависимости, portupgrade от pkg ??
Если так то чем они связаны? 8)


 
Antonio
Окт 5, 2015 at 13:41

Нет, причем тут portupgrade и зависимость его.
Речь о том что если есть утилита portupgrade, то можно им обновить pkg.


 

Написать


Копирование информации с сайта возможно только с указанием прямой ссылки - https://nemcd.com